Difference between revisions of "PointMan: Hardware and Software Requirements"

From ProStar Geocorp
 
(17 intermediate revisions by 2 users not shown)
Line 1: Line 1:
  
Pointman is designed to operate on Android tablets running Android 4.4 (KitKat) although ProStar recommends Android 5.1.1 as older versions are no longer supported by Google and may present security vulnerabilities.<br/> &nbsp;
+
Pointman is designed to operate on Android tablets running&nbsp; Android 7.1&nbsp;as older versions are no longer supported by Google and may present security vulnerabilities.
  
 
== '''Tablets''' ==
 
== '''Tablets''' ==
  
The following tablet devices have been fully tested and can be used without issue:
+
The following tablet devices have been fully tested.&nbsp;<u>'''Android 7 or greater and iOS 12 or later'''</u>
  
*Panasonic Tough Pad
+
*Trimble TDC600 (Android)
*Panasonic B1
+
*Samsung Galaxy Tab Active 2
*Panasonic B2
+
*Samsung Galaxy Tab Active Pro
*eCom Tab-Ex 01
+
*Samsung Tab S6&nbsp;and up
*Xplore (RangerX)
+
*4th Generation iPads&nbsp;and up
 +
**Must have GPS & Cellular 
  
== <br/> <br/> '''Mobile&nbsp;Operating&nbsp;System''' ==
+
== '''Mobile&nbsp;Operating&nbsp;System''' ==
  
*Android 5.0 or greater  
+
*Android 7.1&nbsp;or greater
 +
*iOS 12.3 or greater  
 
*1.5 GB RAM minimum  
 
*1.5 GB RAM minimum  
 
*16 GB ROM (disk space) minimum  
 
*16 GB ROM (disk space) minimum  
Line 21: Line 23:
 
*3G network or WiFi (approx 400kbps or higher unless using offline mode)  
 
*3G network or WiFi (approx 400kbps or higher unless using offline mode)  
  
== <br/> <br/> '''Locate&nbsp;Devices''' ==
+
== '''Electromagnetic&nbsp;Pipe Locators (Android & iOS)''' ==
  
The following locate devices have been fully tested and can be used without issue:
+
*Vivax Metrotech vLocPro 2, vLoc3Pro, vLoc3-5000
 +
*Subsite Utiliguard Advanced+
  
{| border="1" cellpadding="1" cellspacing="1"
+
&nbsp;
|-
+
| '''Manufacturer'''
+
| '''Tested Model'''
+
|-
+
| Vivax Metrotech
+
| vLocPro2
+
|-
+
| 3M Dynatel
+
| 7420
+
|-
+
| RadioDetection
+
| RD800/RD8100
+
|-
+
| Fujitech
+
| PL960
+
|-
+
| Subsite
+
| Utiliguard
+
|}
+
  
== <br/> <br/> '''External&nbsp;GPS&nbsp;Devices''' ==
+
== '''Electromagnetic&nbsp;Pipe Locators (Android Only)''' ==
 
+
The following GPS devices have been fully tested and can be used without issue:
+
 
+
{| border="1" cellpadding="1" cellspacing="1"
+
|-
+
| '''Manufacturer'''
+
| '''Model'''
+
|-
+
| BlueStar
+
| BlueStar GPS, BlueStar GNSS, BlueStar RTK, BlueStar SafeRTK
+
|-
+
| Eos
+
| Arrow
+
|-
+
| Geneq
+
| SX Blue
+
|-
+
| Juniper Systems
+
| geode
+
|}
+
 
+
&nbsp;
+
  
== <br/> '''RFID Tag Readers''' ==
+
*RadioDetection 8000, 8100&nbsp;'''(Android Only)'''  
  
The following RFID readers have been fully tested and can be used without issue:
+
== '''GPS/GNSS Receivers''' ==
  
{| border="1" cellpadding="1" cellspacing="1"
+
*BlueStar '''(Android & iOS)'''
|-
+
*EOS Arrow Blue, Green, Gold (RTK) '''(Android Only)'''  
| '''Manufacturer'''
+
*Trimble&nbsp;'''(Android Only - No Data Collector Required)'''  
| '''Model'''
+
**R1, R2, R8, R8s, R10, R10-2, R12
|-
+
**SPS985, SPS986 
| TSL
+
*Spectra Precision SP80, SP85
| 1153, 1166
+
*Genec Silver&nbsp;'''(Android)'''
|}
+
*Juniper Geode&nbsp;'''(Android)'''
 +
*Juniper Geode GNS2'''(Android & iOS)'''
 +
*Emlid Reach RS+, RS2&nbsp;'''(Android)'''

Latest revision as of 14:34, 18 December 2020

Pointman is designed to operate on Android tablets running  Android 7.1 as older versions are no longer supported by Google and may present security vulnerabilities.

Tablets

The following tablet devices have been fully tested. Android 7 or greater and iOS 12 or later

  • Trimble TDC600 (Android)
  • Samsung Galaxy Tab Active 2
  • Samsung Galaxy Tab Active Pro
  • Samsung Tab S6 and up
  • 4th Generation iPads and up
    • Must have GPS & Cellular

Mobile Operating System

  • Android 7.1 or greater
  • iOS 12.3 or greater
  • 1.5 GB RAM minimum
  • 16 GB ROM (disk space) minimum
  • Tablet- 8 inch screen or greater
  • Phone- 5.1 inch screen or greater
  • 3G network or WiFi (approx 400kbps or higher unless using offline mode)

Electromagnetic Pipe Locators (Android & iOS)

  • Vivax Metrotech vLocPro 2, vLoc3Pro, vLoc3-5000
  • Subsite Utiliguard Advanced+

 

Electromagnetic Pipe Locators (Android Only)

  • RadioDetection 8000, 8100 (Android Only)

GPS/GNSS Receivers

  • BlueStar (Android & iOS)
  • EOS Arrow Blue, Green, Gold (RTK) (Android Only)
  • Trimble (Android Only - No Data Collector Required)
    • R1, R2, R8, R8s, R10, R10-2, R12
    • SPS985, SPS986
  • Spectra Precision SP80, SP85
  • Genec Silver (Android)
  • Juniper Geode (Android)
  • Juniper Geode GNS2(Android & iOS)
  • Emlid Reach RS+, RS2 (Android)